Air Conditioning smell like a dead fish, weird belt noise (or wind noise) - Kia Forte Forum : Sedan / Koup / Forte5 Forums
User Tag List

Reply
 
Thread Tools
#1 Old 06-11-2012, 10:57 AM
Member
 
BuhbaForte's Avatar
 
Join Date: Jan 2011
Location: Metro Detroit
Posts: 249
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to BuhbaForte
Default Air Conditioning smell like a dead fish, weird belt noise (or wind noise)

My AC smells likes absolute garbage.

and I've also noticed when I accelerate now, I'm getting a wind (wine-d) sound. Only when I'm accelerating. Can be heard when cruising on the free way. Might try and get a video today and see if it can pick up the audio.

2011 Kia Forte Sedan LX

K&N Aftermarket Cabin Filter - Replacement Oil Cap - Boba Fette Trunk Badge

I'm da potty poopa.
BuhbaForte is offline  
Sponsored Links
Advertisement
 
#2 Old 06-11-2012, 11:02 AM
Senior Member
 
HellaWhiteKoup's Avatar
 
Join Date: Feb 2012
Location: Sydney, Australia
Posts: 831
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I see on your sig youre using a K&N cabin filter...not sure if it does any good, but I would recommend replacing it with a new one OR...cleaning it with a K&N kit. As far as I know, it could be the AC filter too having a built up of bacteria due to wet weather. Either replace the filter or get an anti bacterial A/C spray have your A/C on full blast with the windows all down and spray into the AC in the engine compartment.

As for the accelerating sound, I have no idea, better to get that checked out with the warranty
HellaWhiteKoup is offline  
#3 Old 06-11-2012, 11:43 AM
Super Moderator
 
~clover's Avatar
 
Join Date: Jun 2011
Location: PA
Posts: 2,576
Thanks: 419
Thanked 203 Times in 179 Posts
Default

I replaced my filter with a beck & arnley one and it still smells like crap. It's usually just when I first turn it on though and then a few minutes later it's fine. I wonder if the Forte just has a poorly designed A/C system or something cuz I've never had this problem with any other cars...

Previous:
2010 Koup SX 6 spd M/T

Current:
2013 VW GTI w/ convenience and sunroof
~clover is online now  
#4 Old 06-11-2012, 02:53 PM
Senior Member
 
KOUPATROOPA's Avatar
 
Join Date: Jul 2011
Location: Castle Rock WA
Posts: 1,342
Thanks: 3
Thanked 23 Times in 13 Posts
Garage
Default

If I remember correctly there has been other threads on this in the past, not sure if there were any solutions given but I know it has been talked about before. I think the smell is related to a mildew problem or something, if I wasn't on Mobile I would look up that thread and copy the link for you. If you want to do a little searching I am sure you would find the thread, good luck.

Sent from my ADR6425LVW using AutoGuide.Com Free App

2010 Koup
Quad Projectors
LED turn signal modules
LED foglight DRL's
Inovit Speed 18x9+40 with 215/40/18
Lightweight Pulley
"R" Lip spoiler
Road Magnet lowering springs
Cmod front grille

Products that will never again touch my car...Anything made by TB ''Performance Parts''
Stay away guys, they are junk!
KOUPATROOPA is offline  
#5 Old 06-11-2012, 07:24 PM
Senior Member
 
altairpilot's Avatar
 
Join Date: Aug 2011
Location: Seattle
Posts: 488
Thanks: 1
Thanked 4 Times in 4 Posts
Garage
Default

My ac smells gross too at first
altairpilot is offline  
#6 Old 06-11-2012, 07:38 PM
Senior Member
 
shabütie's Avatar
 
Join Date: Aug 2011
Location: Kansas City
Posts: 546
Thanks: 1
Thanked 12 Times in 9 Posts
Garage
Default

My AC smells bad at first too.

I also hear that whiney/wind noise too sometimes, but it is always on this one stretch of road. I'm pretty sure my noise is the sound of the stock tires on the groove pattern of that road.

"Sweet Josephine, will you follow me home?"
shabütie is offline  
#7 Old 06-11-2012, 07:44 PM
Junior Member
 
Join Date: Apr 2010
Location: Tulsa, Oklahoma
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to NeoSober
Default

You might have moisture that built up in your lines or evaporator that enabled mold to grow. There are sprays to kill it or you can just clean out the whole system to be sure.

(make sure your friends didn't throw some anchovies down your vent for fun)
NeoSober is offline  
#8 Old 06-12-2012, 12:02 PM
Member
 
Lappa's Avatar
 
Join Date: May 2010
Posts: 139
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I dno what the smell is, but the winding noise is the A/C Compressor, mine does it alot too. Mine is also accompanied with some gurgling.

2010 Forte EX 2.0L 5spd M/T
Lappa is offline  
#9 Old 06-12-2012, 12:15 PM
Legendary Member
 
AutoItKing's Avatar
 
Join Date: Jan 2011
Location: Austin, TX
Posts: 1,987
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Default

To fix the smell, turn off your A/C a minute before turning off your car. So like a block away from your destination. Leave the fan on though. This allows the coil to warm up and keeps it from condensating. The condensate is what ends up smelling bad.

White 2010 EX Sedan
Solo Performance Cat-Back (QR/Mach) + high flow cat
Custom CAI
RoadMagnet Springs
Broken K badges
Koup EX wheels
Projector Retrofit; 4300k lows, 3000k highs
(Much more info in garage)
AutoItKing is offline  
#10 Old 06-12-2012, 02:18 PM
Premium Member
 
Maximilien's Avatar
 
Join Date: May 2011
Location: Cleveland, Ohio
Posts: 1,118
Thanks: 0
Thanked 1 Time in 1 Post
Default

Search for the other threads

Your EVAP is condensating water and bacterial/mold/mildew are breeding in your HVAC system

There is a TSB to fix this issue. It involves the Dealer treating the EVAP with some disinfectant and odor remover.

IF you want an immediate fix get one of these. It has an activated charcoal filter and baking soda. It will mask the issue till you get it in to the Dealer for the TSB

I put one in my car and all HVAC smells went away.

FRAM Fresh Breeze® Cabin Air Filter | FRAM®


2011 Forte 5 X
Metal Bronze
Premium Package
Maximilien is offline  
#11 Old 06-13-2012, 07:36 AM
Member
 
BuhbaForte's Avatar
 
Join Date: Jan 2011
Location: Metro Detroit
Posts: 249
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to BuhbaForte
Default

Awesome guys, thanks for all the great responses. I'll try a few things out.

2011 Kia Forte Sedan LX

K&N Aftermarket Cabin Filter - Replacement Oil Cap - Boba Fette Trunk Badge

I'm da potty poopa.
BuhbaForte is offline  
#12 Old 06-13-2012, 12:51 PM
Junior Member
 
Join Date: May 2012
Location: Upstate NY (NOT N.Y.C.)
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've had the bad smell in just about every car I've had until I made it a habit to always turn off the A/C 1 or 2 minutes from reaching my destination...just long enough for the A/C to stop blowing cold air.

No condensation, no smell.
No filters, sprays, or disinfectants required.
joester is offline  
#13 Old 06-13-2012, 01:01 PM
Senior Member
 
Rawad's Avatar
 
Join Date: Oct 2011
Location: Lebanon
Posts: 1,260
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You should always turn off your ac before you switch off your car anyways, just saying, dont leave it on.

'11 Black Koup
154 horses of fury

Quote:
Originally Posted by bigbossman View Post
Take it as a compliment. Even haters watch your videos
Quote:
Originally Posted by Pezey View Post
Not trying to be a smart ass, I swear- but it is impossible to fit a solid 16" through a solid 15.5".
Rawad is offline  
#14 Old 06-25-2012, 11:50 AM
Junior Member
 
shmilymann's Avatar
 
Join Date: Sep 2011
Location: Trinidad & Tobago
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
shmilymann is offline  
#15 Old 06-25-2012, 12:35 PM
Senior Member
 
tyzall1584's Avatar
 
Join Date: Mar 2011
Location: Richmond,VA
Posts: 543
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have not had this issue, but I rarely run the AC. Usually I will run it if the car is just breathtakingly hot when I first get in it, but once I get on the highway, I turn off my AC and open my windows. It always smells like new car to me :-)

2011 Forte Koup SX
6 speed A/T
"SI Spoiler"
Pinstripes on front bumper
Painted calipers
Red stitched shifter boot
TK CAI
tyzall1584 is offline  
Reply

Bookmarks

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off