Bluetooth Audio Issues - Kia Forte Forum : Sedan / Koup / Forte5 Forums
User Tag List

 
Thread Tools
post #1 of 5 Old 05-16-2019, 11:12 PM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Bluetooth Audio Issues

Hello to all. I've come to you hoping for answers to my Bluetooth Audio issue.
2012 5 door EX all stock

Old phone... iPhone 5s (BT version 4.0 A2DP) pairs nicely, phone and contacts are good, AND google maps uses audio system alongside the radio for verbal navigation.

New phone... 2019 Motorola G7 (android, BT version 4.2 LE A2DP, aptX) pairs fine, phone and contacts are good, BUT google maps does not use audio system alongside the radio for verbal navigation.
To hear navigation I must use Aux.
The phone sees the car as a headset, I don't know why. Motorola and Kia had no solutions other than to say they don't know or the phone is too new. ��

Ideas? Save me from having to go back to the iPhone. Thanks very much.

Last edited by Mhaley1156; 05-16-2019 at 11:18 PM. Reason: Bold
Mhaley1156 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-17-2019, 08:20 AM
Member
 
carl_2112's Avatar
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 175
Drives: 2014 Kia Forte5, 1996 Nissan 300zx twin turbo
Thanks: 1
Thanked 11 Times in 10 Posts
Garage
Open Google Maps.

Click the menu icon.

Scroll down to find Settings and click it.

Scroll down to find Navigation Settings and click it.

Check "Play voice over Bluetooth"
carl_2112 is offline  
post #3 of 5 Old 05-17-2019, 10:52 AM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Hey Carl... Thanks for the reply

Voice over BT has been set from the start, so has the BT link set to play media audio through it. Basically all settings are as they should be, even per Motorola during a remote access support session
Google maps no go except for Aux. Same thing for testing google sound. Nada... unacceptable.

I think we may have no love between audio codecs on both ends. I dunno.
Mhaley1156 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 05-17-2019, 02:29 PM
Member
 
carl_2112's Avatar
 
Join Date: Jul 2015
Location: Austin, TX
Posts: 175
Drives: 2014 Kia Forte5, 1996 Nissan 300zx twin turbo
Thanks: 1
Thanked 11 Times in 10 Posts
Garage
That's really weird then. I also have a G7, but I replaced my head unit with a Sony that does Android Auto, so I plug my phone in via the USB interface to get all the Android Auto goodies. But I do get voice directions if I unmute maps. I usually keep it muted though.

Can you play music from your phone over BT?

Can you borrow some friends' phones of different types and see if it's a more general android issue or just specific to your G7?

My guess is it's likely an issue with your 7 year old stock head unit though.
carl_2112 is offline  
post #5 of 5 Old 05-17-2019, 03:08 PM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Carl, I found a solution, more or less, Though it's a little different than what I'm used to.

I installed Spotify along with my four favorite radio stations using an app. I pair up the G7, load google maps and a music source, press Aux for the input and everything works. It's a workaround in my book, but having my radio stations, Spotify Andvocal navigation as I wanted I am good to go.

This may be as good as it gets or there's another solution floating around here.
Thanks Carl
Mhaley1156 is offline  
Reply

Bookmarks

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth issues with my 2014 Forte5 EX UVO (non-nav) carl_2112 Forte Audio, Video and Electronics 2 09-17-2015 02:21 PM
Issues issues issues with keyless Denedil Forte Audio, Video and Electronics 1 11-16-2014 11:11 AM
Bluetooth sound issues njbuckeye Forte Audio, Video and Electronics 1 09-03-2011 03:23 PM
Bluetooth issues limodude Forte Audio, Video and Electronics 5 09-22-2010 03:29 PM
Audio System Recall (Bluetooth Issue) ile2010 Forte Audio, Video and Electronics 9 12-07-2009 02:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off