Kia Forte Forum banner

1 - 4 of 4 Posts

·
Registered
2010 Kia Forte Ex
Joined
·
17 Posts
Discussion Starter · #1 ·
My Cruise Control broke awhile ago, Is there a fuse for Cruise Control? and is this a common problem with 2010? and what are some simple fixes that might get this working again?
 

·
Registered
Joined
·
2 Posts
Hey bro, same issue here... No fuse, unfortunately... It broke few weeks ago, and before it fail totally, I had to hit the remote on the sterring wheel to make it works... And impossible to know where that's come from... I changed the remote on the sterring wheel, checked switch on brake pedal, speed sensor on the gear box... No ideas where it comes from... If someone have a similar experience, please, feel free to share and help.
 

·
Registered
Joined
·
2 Posts
Hey bro, same issue here... No fuse, unfortunately... It broke few weeks ago, and before it fail totally, I had to hit the remote on the sterring wheel to make it works... And impossible to know where that's come from... I changed the remote on the sterring wheel, checked switch on brake pedal, speed sensor on the gear box... No ideas where it comes from... If someone have a similar experience, please, feel free to share and help.
By the way, I have the same mileage and engine than you, the G4KD 2.0L
 

·
Registered
2010 Kia Forte Ex
Joined
·
17 Posts
Discussion Starter · #4 ·
I still have had no luck, I checked my fuses today and could t find a cruise control fuse I may check my relays tomorrow, then start with new switches. I heard tie rod ends could maybe effect this? Idk tho.
 
1 - 4 of 4 Posts
Top