Kia Forte Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Team,

I bought a salvage 2020 forte lxs with 2k miles in the auction. Little did I know it was a theft recovery and it came with a blown engine. I ended up ordering an engine with 4k miles and installed it. The car cranks but doesn't start. Replaced faulty starter and will replace fuel pump tomorrow. Any other thoughts on what I should check outside of spark and fuel?

Appreciate yall.
 

·
Registered
'21 GT Manual
Joined
·
49 Posts
Can always try a little starting fluid, if it runs for a bit, your issue is with fuel delivery, could be computer related. If it does not run with starting fluid it may be that the spark timing is off or it's firing the wrong cylinders. A video of the issue could help the internet collectively diagnose the problem as well. Good luck, keep us updated!
 

·
Registered
Joined
·
2,751 Posts
Other ideas: Crank sensor relearn. Computer issues. Wires installed incorrectly/not connected/ground(s) not effective. Fuse burned out/circuit breaker tripped.

Definitely keep us updated!
 

·
Registered
Joined
·
2,751 Posts
Those little OBD2 readers sure come in handy for something like this...maybe.
Normally I'd agree with you...but, since the engine isn't running there would be no way DTCs would be set as the data wouldn't accumulate in the required time parameters...and the ability to monitor most areas is hampered as well.

Correction - he should use a scan tool to see if he can even connect to the ECM - to check that it is getting power and it is functioning!
 
1 - 7 of 7 Posts
Top