Kia Forte Forum banner
21 - 35 of 35 Posts

·
Registered
Joined
·
123 Posts
Mindthe time. What exactly were your lights doing? I'm just experiencing flickering. Nothing with brakes or turn signals. Although I have had to change brake light, turn signal, & park light bulbs. Some more than once & noticed that my dash will indicate turn signal bulb is out but bulb is fine. Confused where to start to correct my issue?
A small amount of flicker is normal on these cars.
 

·
Registered
Joined
·
5 Posts
Glad I stumbled onto this ,my 2010 does the same thing. Lights flicker at idle, radio cuts out if I hit the brakes or use the turn signal, sometimes. Also my door locks don't always work right and sometimes it glitches when it starts and throws coolant sensor codes. I was worried it might some wierd computer problem. From this is sounds like its just pretty much your basic electrical gremlins some cars seem to have. Which I hate, had I known it when I got the car I would not have bought it. Electrical problems are such a pain to find and fix. This has given me a few places to start though.

I was going to take it to the dealer, but the more I read about people doing this for these types of problems they just seem to get ripped off and never end up getting it fixed. I think maybe I will go get the charging system tested to start with. Then clean the battery terminals and start probing different spots with a meter. A .3 voltage drop made that big of a difference huh? I would have just overlooked that as normal. Mine really isn't doing anything that hinders how it drives. It is just kind of annoying is all. And I am kind of worried it might just quit running out of the blue.

Sad thing is I just bought it in august so I am stuck in the loan since I owe way more than the car is worth. Hopefully it will run for 3 or 4 years and I can trade it in on something different.
 

·
Registered
Joined
·
230 Posts
hi, i sure realized and that was the reason i asked since maybe someone will know the answer to this issue after more then a year, it's been around in my car for few months now and 2 different car mechanics couldn't find anything, i will look at the ground direction suggested above and update this thread.
Mine too 2 mechanics 2 new alienators and same issue
 

·
Registered
Joined
·
230 Posts
Glad I stumbled onto this ,my 2010 does the same thing. Lights flicker at idle, radio cuts out if I hit the brakes or use the turn signal, sometimes. Also my door locks don't always work right and sometimes it glitches when it starts and throws coolant sensor codes. I was worried it might some wierd computer problem. From this is sounds like its just pretty much your basic electrical gremlins some cars seem to have. Which I hate, had I known it when I got the car I would not have bought it. Electrical problems are such a pain to find and fix. This has given me a few places to start though.

I was going to take it to the dealer, but the more I read about people doing this for these types of problems they just seem to get ripped off and never end up getting it fixed. I think maybe I will go get the charging system tested to start with. Then clean the battery terminals and start probing different spots with a meter. A .3 voltage drop made that big of a difference huh? I would have just overlooked that as normal. Mine really isn't doing anything that hinders how it drives. It is just kind of annoying is all. And I am kind of worried it might just quit running out of the blue.

Sad thing is I just bought it in august so I am stuck in the loan since I owe way more than the car is worth. Hopefully it will run for 3 or 4 years and I can trade it in on something different.
Did you end up finding solution?
 

·
Registered
Joined
·
3 Posts
i can’t get the link to work, but an update it’s been fixed! New voltage regulator new fuse panel every ground cleaned throughout the car, took it to the mechanic again they ran 10 gauge wire to the fuse panel from a splitter they put on the positive battery cable.. it *** worked!
Do you have pictures
 

·
Registered
Joined
·
3 Posts
The flickering looks like a starter solenoid, alternator. battery?

Did you check visually all fuses are good still?
I check all fuses. I even cleaned my ground wires going to the chassis. I thought it could be my battery so i purchased a new one. The flickering is only in the inside of the vehicle. My dome light and door light is the only parts that havingthe issues. It steady up until the key is turned forward or the engine is running at idle. I replaced the bulbs also and no luck.
 

·
Registered
2021 Kia Forte GT-Line
Joined
·
366 Posts
Possibly the switches in the door post . They work off ground. Can find them on Amazon for less than $10. Just remove them and disconnect one at a time to check them. When one is disconnected light won't come on when that door is open. Both disconnected no light at all.
 

·
Registered
Joined
·
3 Posts
No codes, it just my Interior lights thats flickering when i turn the key forward or when the car is in park or idling. Its not bad buts its irritating when i open my door at night and the bulbs are flickering
 
21 - 35 of 35 Posts
Top