Kia Forte Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I now have 13,700 miles on my Forte and overall I am happy with the car. I do have 3 problems that keep coming back and I hope someone else has had the same issues since the service department hasn't been successful:

1. Sirius would lose the signal just in my neighborhood but my friends Hyundai Elantra would never lose the signal in the same exact areas. A new radio was replaced and is better but not the same as my friends.

2. When I receive a phone call to my paired phone, 90% of the time when I click on to answer the call, I get "call rejected" as if I hit the hang-up button. The service department says they can't duplicate the problem.

3. My steering wheel radio controls seem to get 'mixed up' where as I would try to adjust the volume up and it would go down. At the same time I would click MODE and it would mute. If I click on the arrows, it would change the mode or volume.

My car is due to go into the service department for the 3rd time on Wednesday and I hope someone else has had one or all of these problems with a solution.

Otherwise, I have happy. I drive about 95% highway through Philadelphia and I am getting about 30mpg if I keep the speed at 58mph. I did a 300 mile all highway trip at 65mph and got 38mpg.

Thanks

Jim
WA3ERQ
 

·
Premium Member
Joined
·
905 Posts
Sorry to hear that. I haven't had any electrical problems with mine. Yours all seem like they could possibly be related. Hopefully one item being replaced will address all the problems.

I am getting the same treatment from my local dealer...can't recreate the problem, can't help you. Its infuriating when you have an issue that only happens sporadically.
 

·
Registered
Joined
·
348 Posts
Sounds like the clock spring has a short in it. Nearly every issue you have is with the steering wheel controls, and they all run through there. Other Kias have HUGE problems with them, and we have seen a few Fortes now as well.

As for the Sirius, it's likely limited to the antenna as we have had a few customers with the same issue. Factory Sirius cuts out while an aftermarket add-on one shows full bars. We have not really gone too much further with the troubleshooting on this.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Thanks for the advice guys. I just got off the phone with a service manager for tomorrows appointment and explained my issues. As far as the Sirius, Is there anything that I can do such as replace the antenna?

Thanks
 

·
Registered
Joined
·
45 Posts
The only issue I have had since I bought the car 3 weeks ago is with the bluetooth. It connects just fine but even with the volume at max its ever so quiet. Its going into the dealer for another issue (switch for dome light was never hooked up so when I open the door no lights come on) and I will have them check it out.
 

·
Registered
Joined
·
348 Posts
It's been a while since I have seen the rear of the radio unit, but I don't think the Sirius antenna connection is the 'standard' one for the kits, etc. I think it's a bit smaller but I could be wrong. I'd love to say that it's the same and it's a easy fix but I am just not able to.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Just FYI in case anyone is interested. The service department stated that they could not recreate the problem. Their tech-support suggested using a sealant on the plugs. I've asked them to keep the car for another day and drive it around to see if turning the wheel has any effect on the performance and hopefully they can recreate the problem.

To KiaTech. I asked about the antenna since I've researched Sirius and know that they have a few repeaters in the Philadelphia area. According to maps that I've located on line, there really should'nt be any dead spots and since I work at Phila Intl Airport and park on the gararge roof, I expect 100% reception due to a clean line of site to both the satallites and any repeaters. Even then, I lose the signal sometimes for a few seconds (which could be the radio moving from the satallite to the repeater).

Being a Ham radio operator, I have no problem installing an external antenna if it helps but I'm hesitant to open the dash to avoid voiding the warranty in some manner.

Tnx
Jim
 

·
Registered
Joined
·
132 Posts
I now have 13,700 miles on my Forte and overall I am happy with the car. I do have 3 problems that keep coming back and I hope someone else has had the same issues since the service department hasn't been successful:

1. Sirius would lose the signal just in my neighborhood but my friends Hyundai Elantra would never lose the signal in the same exact areas. A new radio was replaced and is better but not the same as my friends.

2. When I receive a phone call to my paired phone, 90% of the time when I click on to answer the call, I get "call rejected" as if I hit the hang-up button. The service department says they can't duplicate the problem.

3. My steering wheel radio controls seem to get 'mixed up' where as I would try to adjust the volume up and it would go down. At the same time I would click MODE and it would mute. If I click on the arrows, it would change the mode or volume.

My car is due to go into the service department for the 3rd time on Wednesday and I hope someone else has had one or all of these problems with a solution.

Otherwise, I have happy. I drive about 95% highway through Philadelphia and I am getting about 30mpg if I keep the speed at 58mph. I did a 300 mile all highway trip at 65mph and got 38mpg.

Thanks

Jim
WA3ERQ


I just posted a thread a week or two ago (can't find it now...) anyways it was regarding the same similar issues.... My steering wheel volume control has been triggering my bluetooth to "listen" ...
My sunroof switch intermittently works along with the dome lights part of that same console..
And even my horn has worked intermittently...

Anyways just got back from the dealer today and from everything he checked out all my wiring and switches were all functioning and of course he couldn't re-create my problems either EXCEPT finally the sunroof switch didn't work properly when he tried using it...

Anyways long story short, hes ordered that front ceiling console with new lights and sunroof switch to see if maybe it was just a faulty switch, which from what I gathered could cause other electrical issues.. so once I have the new part installed i'll report on the rest of my electrical problems!
Good luck to you man!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
KoupKid905;

Just got a call from the service manager. After they could'nt find the problem, I asked them to drive the vehicle and try again. I can't believe that I reported steering wheel issues and they never thought to "move the wheel". After MY suggestion, they recreated the problem but their "tech support" has no idea what to do. Tomorrow will be day 3 in the shop due to this problem.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Just got my car back and it will return to the shop next week. The service dept has no idea what the problem is so they are going to replace all of the steering wheel buttons and unfortunately, they are coming from California so I have to wait until at least Tuesday. To make matters worse, the new radio is still losing the signal almost 50% of the time. The only good part is that the service manager has acknowledged that there is a problem.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top