Kia Forte Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter · #1 ·
Haven't really had time to look into it but apparently i always have time for the forum haha. With that said:

I have an iphone 4 that i use with the bluetooh in my 2011 Koup SX
When i use the voice command to dial numbers it runs the names by last name first

EX "Calling Smith, John on mobile."

Is there any way to make it say the name the right way? First THEN last?
 

·
Registered
Joined
·
35 Posts
I also have the iphone 4 and mine is First then last... it may actually be how the iphones directory is set up...

Here try this...
Go to the "Settings" icon and tap it.

Tap the "Mail, Contacts & Calendars" option after you've opened the "Settings" menu. Scroll down until you see "Contacts."

Tap "Sort Order," then choose "First, Last." This action will sort your contacts in alphabetical order by the first name. If you want to further change how the contacts are displayed

Tap "Mail" on the top left corner of the screen to go back to the "Mail, Contacts & Calendars" menu.

Tap "Display Order" under "Contacts" and choose "First, Last." This will ensure that your contacts folder is not only sorted by first name, but displayed that way as well.

Go to your contacts book to make sure the order has changed.

Got the steps from: How to Change the Contacts on iPhone to the First Name | eHow.com

-Kris
 

·
Registered
Joined
·
257 Posts
I have an iPhone 4 as well and mime goes last name first and mine is setup the way your saying to set it up first name then last in my phone
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #4 ·
Yeah mine's all set up first, last. Never understood having last name first.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #5 ·
Bump

Still an issue
 

·
Registered
Joined
·
85 Posts
Ok so I figured it out for my Droid instead of splitting up the names is the phone books

IE

John
Smith

I put the name on one line

IE

John Smith

the car now recognizes and says the name in the correct order.
 

·
Registered
Joined
·
25 Posts
I have a Droid Incredible and have the same issue. I have them listed as FirstName LastName in Contacts. I also noticed that if I have a company as a contact, the name is simply registered as a LastName. If that company contact has a LastName made up of more than one word like "Pizza Hut" I still have to say "Hut Pizza".

One possible work around that I have been kicking around... changing the names around and then save it as a custom vcf file. Then sync that vcf file with the car and restore the original contacts on the phone. I'll let you know if it works.
 

·
Registered
Joined
·
124 Posts
Discussion Starter · #10 ·
I'll try throwing them all on the same line which is going to be a bitch but hopefully that'll work. I'll update tomorrow and let you know.
 

·
Registered
Joined
·
25 Posts
Success! Here's how I got it working... I created a new vcf file just for the car. I swapped the FirstName and LastName for people listed in my contacts. I deleted the phone from the car then paired it back up. Once it connected and the address book sync'd up it started working. Once I verified that it worked, I turned off the "Sync Contacts" option on the stereo. Then I cleared the backwards contacts on my phone and restored my originals contacts.
Now I can say, "Call John Doe" and it actually works. Also, businesses contacts are normally just added as a FirstName or LastName, not both. Just put the last word of the business name in the beginning of the entry. For example, "Gander Mountain" becomes "Mountain Gander" on the same line. Also, if you have any entries that are 3 or more words you will need to put the last word first and then hyphenate the first two. For example, "Papa John's Pizza" becomes "Pizza Papa-John's". Or if it's a FirstName LastName contact like "John & Jane Doe" it becomes "Doe John-and-Jane".
 

·
Registered
Joined
·
344 Posts
^brain hurts but will...try...to....read slower.
 
1 - 12 of 12 Posts
Top