Kia Forte Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello, I have a 2012 Forte sx hatchback.
It seems like when I'm switching on the AC, the car starts shaking more.
I've recently replaced the spark plugs, because time has come, I'll fix the VCMA part and then, I am going to look into this.
Additionally, the lights are flickering a little when running, so, it's either serpentine belt (first, check tension and/or replace) or alternator (will be clear after serpentine belt replacement) or right engine mount?
Ideas?
 

·
Registered
Joined
·
1,020 Posts
I'd first check all of the ground connections. Kia/Hyundai uses the very poor practice of attaching body grounds to painted surfaces, and there have been multiple reports on the forums of various problems being resolved when those connection points were sanded down to bare metal. Although it's possible that your vehicle has multiple issues, the flickering lights is definitely a smoking gun for poor grounds.
 

·
Registered
Joined
·
3 Posts
Hello, I have a 2012 Forte sx hatchback.
It seems like when I'm switching on the AC, the car starts shaking more.
I've recently replaced the spark plugs, because time has come, I'll fix the VCMA part and then, I am going to look into this.
Additionally, the lights are flickering a little when running, so, it's either serpentine belt (first, check tension and/or replace) or alternator (will be clear after serpentine belt replacement) or right engine mount?
Ideas?
Have your engine and trans mounts checked. Cured my vibration issue.
 
1 - 5 of 5 Posts
Top