Kia Forte Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I love my cruise control and use it a lot.

However, I noticed something odd, which could be a simple bug... When I have cruise control set, there is a green indicator on the dash, that I think says "SET". However, when I touch the gas to speed up, it stills says "SET" even though, I don't think keep the car at the speed limit that I set.

Example: I set my cruise control for 120KM, the word "SET" is on the dash, I press the gas pedal, and speed up to 130KM, let my foot off the gas, the SET is still on the dash, but the needle won't stop at 100KM...

Bug?
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
3,820 Posts
That's normal. The "Set" is just telling you that cruise is engaged...if you let off the gas it will return to your original "set" speed.

What should happen is you set the speed at 70 MPH and push on the gas to pass a slower car, increase your speed to 75 MPH for example, then when you let off the gas your car should go back to 70 MPH.
 

·
Registered
Joined
·
139 Posts
Yeah, you can manually drive faster than the 'set' speed, but the car wont go past the set speed on its own. It will only disable when brakes or the clutch are applied.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #4 ·
However, I would think, if it says "SET" and I hit the brakes, or clutch, the light should go off, no? I don't believe mine does, as the speed is no longer "SET"
 

·
Registered
Joined
·
78 Posts
It's not a bug its..............


gremlin definition

grem·lin (gremlin)
noun
a small imaginary creature humorously blamed for the faulty operation of airplanes or the disruption of any procedure
 

·
Registered
Joined
·
139 Posts
However, I would think, if it says "SET" and I hit the brakes, or clutch, the light should go off, no? I don't believe mine does, as the speed is no longer "SET"
If the 'Set' light doesnt turn off when the brakes or clutch is applied, theres a big problem and i suggest not using CC.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #8 ·
My Cruise Control works as advertised. I tested it fully today. SET went off after braking or clutching, and when "cruising" and then accelerating, the speed dropped back to the SET speed once I took my foot off the accelerator.
 
1 - 9 of 9 Posts
Top