Kia Forte Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
This is getting a little ridiculous. :mad:
Last Thursday I got in my 6 speed SX Koup and started up the cart and left for work. I dropped my kid off at school but she left something in the car so I went to honk the horn and NO horn. It worked the day before. I thought well maybe turn the car off and back on, still did not work. I drove too work testing the horn constantly (surprised I didn’t set of the air bag). Came back out during lunch and drove my car to get food, still NO horn. Drove the car all the way home and to the store later that night, still NO horn.
Friday I get up and go through the same routine and the Horn still does not work and as a special bonus now the drivers Air Bag Malfunction light is stuck on so, NO HORN and NO Air BAG!
So I drop the kid off at school, do the power on and off again with no change. Drove all the way to work and turn the car off. After work I come out and test the horn and low and behold it worked and when I started the car the Air Bag light performed normally and turned off after 3 seconds.
During that time I noticed that I could not use my hands free for my cell phone because the system was picking up so much static that it was un-usable and I would have to turn off my Bluetooth to use my phone in hand.
Monday brought a NEW problem, my horn was working, Air Bag was working but now the TPMS light was stuck on and did not go off after 20 minutes like it was supposed to and it was still on when I drove home so I have a Tire Pressure Management System that is malfunctioning NOW!
What’s next the steering?
Oh never mind that has tweaked out twice and almost caused me to wreck at low speed into a concrete barrier. When you turn the wheel that hard it pulls back and can rip the steering wheel out of your hand if you aren't gripping it tight enough.
Has anybody else had any issues similar to this?
 

·
Premium Member
Joined
·
982 Posts
I've had the TPMS light stay on for no apparent reason. Also, a week ago I started the car and it had some problem turning on, I started driving and the car would not go past 3,000 rmp (exactly!!!). I turned it off and on, and everything was back to normal. Dealer will probably not find any problems, but I would still go and document your problems... DOCUMENT EVERYTHING
 

·
Registered
Joined
·
587 Posts
Hey Brian....man that really sucks. I know that if those issues were happening to me, I would be losing my mind and totally pissed off. I wish you all the best and sure hope that all the issues get resolved in a timely manner, and you can once again enjoy your ride.
So keep us posted please.

All the best.
 

·
Registered
Joined
·
1,796 Posts
I heard that the TPMS light will behave erratically if the gas cap is not tight on the Fortes. Don't know whats up with the horn/airbag/steering things though. I haven't had any issues with mine.
 

·
Registered
Joined
·
76 Posts
All the buttons on the steering wheel most likely go into a single unit that handles those signals. I've seen em fail to initialize properly and cause all kinds of problems with radio, bluetooth, horn, etc. May never happen again. My TPMS light was on for a single trip of about 100 miles, never has come back on and I did not need to adjust tire pressure or gas cap. Next time I got in the car, all is good.
 

·
Registered
Joined
·
1,796 Posts
Just saying that next time you get the TPMS light trying checking cap to see if that fixes it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #8 ·
Factory stereo replacement just authorized!

:confused:
Well,
It has been a couple of months since I created this post and the only thing that has come of it is that the dealer needs to replace my radio due to the afore mentioned problems.
Right after the other Electrical issues I was having, the Hands Free in my car started generating a horrible echo and static when I was talking.
Out of the 3 defects this is the only one that was persistent enough to warrant a look see.
The replacement is on order and will be installed on Aug 9th 2010.
I will let everyone know what happened.
BCB
 

·
Registered
Joined
·
1 Posts
This exact Problem happened to me last night, i went to lock the car and no horn? So i check the doors and trunk to make sure that they are closed. Tried to lock the car again nothing. Get in the car and cranked it and hit the horn and still nothing. Turned it off and back on and still nothing. Then i gave up got out and locked it and it honked. I've also had problems with a drivers door sensor that took 2 trips to the dealer to fix. and the winshield wipers too. Of course the dealer was unable to find any problem with that. I'm starting to wonder if this car is going to have major electrical problems later on down the road. So glad i bought the 10 year 100,000 bumper to bumper warranty.



This is getting a little ridiculous. :mad:
Last Thursday I got in my 6 speed SX Koup and started up the cart and left for work. I dropped my kid off at school but she left something in the car so I went to honk the horn and NO horn. It worked the day before. I thought well maybe turn the car off and back on, still did not work. I drove too work testing the horn constantly (surprised I didn’t set of the air bag). Came back out during lunch and drove my car to get food, still NO horn. Drove the car all the way home and to the store later that night, still NO horn.
Friday I get up and go through the same routine and the Horn still does not work and as a special bonus now the drivers Air Bag Malfunction light is stuck on so, NO HORN and NO Air BAG!
So I drop the kid off at school, do the power on and off again with no change. Drove all the way to work and turn the car off. After work I come out and test the horn and low and behold it worked and when I started the car the Air Bag light performed normally and turned off after 3 seconds.
During that time I noticed that I could not use my hands free for my cell phone because the system was picking up so much static that it was un-usable and I would have to turn off my Bluetooth to use my phone in hand.
Monday brought a NEW problem, my horn was working, Air Bag was working but now the TPMS light was stuck on and did not go off after 20 minutes like it was supposed to and it was still on when I drove home so I have a Tire Pressure Management System that is malfunctioning NOW!
What’s next the steering?
Oh never mind that has tweaked out twice and almost caused me to wreck at low speed into a concrete barrier. When you turn the wheel that hard it pulls back and can rip the steering wheel out of your hand if you aren't gripping it tight enough.
Has anybody else had any issues similar to this?
 

·
Registered
Joined
·
1,796 Posts
I wonder if there is an issue with the grounding straps for all of these electrical issues. You would get alot of static from the audio if not grounded properly. Anything electrical can have very strange issues just by not having a good ground.
 

·
Registered
Joined
·
132 Posts
I've had the intermittent horn issues as well and of course when you take the car to the dealer the horns seems to work EVERYTIME... however I had a few other electrical problems one with the controls on my steering wheel and the other with my sunroof switch... FINALLY the sunroof switch glitched out for the service guy at the dealer so he could see I wasn't actually crazy... anyways needless to say they are replacing the sunroof switch and the two dome lights part of that fixture... but the horn issue still remains a mystery! Theres gotta be something wrong if so many of us are having the same issues!
 

·
Registered
Joined
·
126 Posts
I'm just thinking... how about unplugging the battery for 5-15 seconds... a reboot, so to speak...

Try it and see what happens.

******
 

·
Registered
Joined
·
3 Posts
Just got my Forte a week ago and it's going into the shop because the horn doesn't work. Everything else works ok. I paired my phone to the bluetooth easily and made a call already.
 

·
Registered
Joined
·
132 Posts
Update

So Just had my car serviced (Service number 3) yesterday! Got the sunroof switch replaced and so far so good... the switch seems to respond right away (before it would take 2 or 3 attempts are getting the roof to open) and as well the dome lights seem to work flawlessly (fingers kept crossed).
But my horn issue (although hasn't happend recently) Still remains a mystery.
A couple other things I noticed one pertaining to the electrical, the other night I dropped something while driving. I pulled over and put my 4 ways on. I turned on both interior dome lights and obviously my headlights were on as well. While I was pulled over I noticed that everytime my 4 ways would flash my interior lights would seem to dim or flicker slightly as if there was a small surge of power or something... so I still insist that there is definitely something electrically wrong with the car i.e. faulty wiring etc. However the dealerships seem to think otherwise, but what do I know right? I just own the car! lol
The only other thing I noticed (somewhat un related to the electrical i would assume) But after having my service 3 done and switch replaced, I was driving home yesterday, I pulled out of a parking lot and gradually started to accelerate and my car SLAMMED into 2nd or 3rd gear..it actually scared the crap out of me...
I know others have mentioned issues like this with the transmission and I have had this happen (not as intense) once when I accelerated quickly going up hill so I didn't really think anything of it... should I be raising some red flags now in the early stages? Like does this sound like my tranny (Auto) could be part of these bad apples per say?

Thanks guys!
 

·
Registered
Joined
·
1 Posts
Well I have intermittent horn issues as well. I have had the issues since getting the care six months ago or so.. On my way into work today it happened again, so I took it directly to the dealer. It was the first time I have been able to demonstrate the issue while it was happening, cause they just treated me like I was crazy otherwise :(

One other thing to note: I have also notices that when the horn doesn't work the cruse control wont work as well.

Either-way an intermittent horn is a serious safety concern for both the passengers of the car and pedestrians.. If this issue is not resolved I think I may have to take legal actions.
 

·
Registered
Joined
·
191 Posts
This is getting a little ridiculous. :mad:
Last Thursday I got in my 6 speed SX Koup and started up the cart and left for work. I dropped my kid off at school but she left something in the car so I went to honk the horn and NO horn. It worked the day before. I thought well maybe turn the car off and back on, still did not work. I drove too work testing the horn constantly (surprised I didn’t set of the air bag). Came back out during lunch and drove my car to get food, still NO horn. Drove the car all the way home and to the store later that night, still NO horn.
Friday I get up and go through the same routine and the Horn still does not work and as a special bonus now the drivers Air Bag Malfunction light is stuck on so, NO HORN and NO Air BAG!
So I drop the kid off at school, do the power on and off again with no change. Drove all the way to work and turn the car off. After work I come out and test the horn and low and behold it worked and when I started the car the Air Bag light performed normally and turned off after 3 seconds.
During that time I noticed that I could not use my hands free for my cell phone because the system was picking up so much static that it was un-usable and I would have to turn off my Bluetooth to use my phone in hand.
Monday brought a NEW problem, my horn was working, Air Bag was working but now the TPMS light was stuck on and did not go off after 20 minutes like it was supposed to and it was still on when I drove home so I have a Tire Pressure Management System that is malfunctioning NOW!
What’s next the steering?
Oh never mind that has tweaked out twice and almost caused me to wreck at low speed into a concrete barrier. When you turn the wheel that hard it pulls back and can rip the steering wheel out of your hand if you aren't gripping it tight enough.
Has anybody else had any issues similar to this?
YES!!!! my horn works once or twice a month! lol and i had the car for about 6 months... My tpms comes on once a month... (Like a girl i think this car has its period every month and throws this random bs at us)
 

·
Registered
Joined
·
1,487 Posts
dropped something while driving. I pulled over and put my 4 ways on. I turned on both interior dome lights and obviously my headlights were on as well. While I was pulled over I noticed that everytime my 4 ways would flash my interior lights would seem to dim or flicker slightly as if there was a small surge of power or something...
Thanks guys!

This part of the story sounds like a bad ground wire on that circuit
 

·
Registered
Joined
·
61 Posts
You guys with the horn/airbag concern need to get the cars to a dealer, have them check the steering roll connector. It's the piece that keeps all the buttons on the steering wheel "connected" while still allowing the wheel to turn. Several manufacurers have had recent recalls due to faulty roll connectors. I'll bet one company makes the majority of these.

To the guy with the dimming lights...that's a normal condition when you have a high amp load while using a flasher. If you think it's a concern, have your battery and alternator tested as if one of those are faulty it can cause similar issues.
 
1 - 20 of 22 Posts
Top