Kia Forte Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
At 800 miles our Forte brakes locked and the engine stalled.

Dealer replaced camshaft assemblies and CVVT gears. Cam gear locating holes deformed.


At 3272 miles the right front tire blew (at 65 mph on turnpike). Both front tires ground down to the belts on inner edges. No prior indication of a problem until perhaps one minute before blowout, when the steering wheel started to vibrate a little bit.

Car towed. Tires replaced. Unable to get alignment.

Visited another shop for alignment. Told we needed both right tie rod ends. NO dealer in the greater Philadelphia area has them. Car too new to need this item.

Parts ordered by a nearby dealer and in two days the tie rods were installed and wheels aligned.

Two weeks after leaving copies of all paperwork and showing the selling dealer the tires and tie rod ends, I have no satisfaction from the local dealer.

I am beginning to wonder if TWO life threatening issues with the car means we have the "lemon" you read about once in a while.

Have not seen anything similar in my Google searches. Anyone else having either of the problems?
 

·
Registered
Joined
·
39 Posts
The roads around Phila are not too great either... 476 and the blue route are both pretty bad and the blvd is NE is just a hazard.
 

·
Registered
Joined
·
973 Posts
it definitely seems like you got one of the very few lemons out there, I've had absolutely NO problems so far, and I'm at 9000 miles now, going up by about 100 every day.
I haven't read anything on here about these problems happening any other time, to anyone else.
maybe the dealer can get you a different koup, because yours is having serious issues.
Best of Luck!
 

·
Registered
Joined
·
1,487 Posts
ooo what a crappy deal, that is like a nightmare I Hope they get you fixed up or getcha another car..
 

·
Registered
Joined
·
202 Posts
wow man that sucks big time, no serious problems with mine, hope you get your forte fix man, best of luck
 

·
Registered
Joined
·
587 Posts
That really sucks. Of course I'm glad that no one was injured.
I wish you all the very best and that all will work out. Do keep us posted.
 

·
Registered
Joined
·
695 Posts
it definitely seems like you got one of the very few lemons out there, I've had absolutely NO problems so far, and I'm at 9000 miles now, going up by about 100 every day.
I haven't read anything on here about these problems happening any other time, to anyone else.
maybe the dealer can get you a different koup, because yours is having serious issues.
Best of Luck!
Corytate, i am in the same spot as you, drive 100 miles a day and around 9,000 miles. Only issue i had was with my side mirror cover..... it fell off doing 105mph on my way to work, running late and didn't stop to attempt to find it. Other than that no real issues.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Photoguy followup

Thanks to everyone for their replies and concerns.

Met with the selling dealer today and he advised me that there appeared to be nothing wrong with my old, original tie rod ends.

Now we wouldn't say that Cherry Hill Kia was greedy and installed parts that actually were not needed... and, oops, almost forgot to mention, charged me $450.79 for the job.

KIA Consumer Affairs will likely have a conversation with them.

At this time we are driving the car, but are very unlikely to ever make a long trip in the Forte 2.4 SX. That's a shame.

Again, your comments were certainly appreciated.
 

·
Registered
Joined
·
25 Posts
Warranty

Hi photoguy,
Sorry to hear about all the issues you are having.
I would have thought that all of the repairs would be covered under the warranty? BTW, Cherry Hill Kia has the most annoying tv commercials.
 

·
Registered
Joined
·
39 Posts
yeah i was just thinking that you said the camber was off on both wheels causing extreme inner edge wear... and you also said that they replaced tie rod ends only on the right side... its not adding up.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
Update number 2

Received payment from KIA for damages. Car appears to be OK at this time. Had tires rotated and second alignment to make sure it was staying accurate.

Again, your comments were appreciated.

Thanks to all!

Jerry
 

·
Registered
Joined
·
587 Posts
It is good to hear that you got some results.

Hows the car driving now?
Will you now be making any 'longer type' trips?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Independence vs. concern!

It is good to hear that you got some results.

Hows the car driving now?
Will you now be making any 'longer type' trips?
My wife drove the car to Philadelphia and Virginia to visit our daughters and grandchildren. The confidence seems to be coming back, particularly after having a dealer we know check the alignment again and rotate the tires.

Questionable news: there is another service bulletin out... and the dealer is waiting for parts. Not unique to KIA, of course... but it appears that all manufacturers are cramming new technology into cars before any long-term testing.

Thanks for asking,

Jerry
 

·
Registered
Joined
·
5 Posts
my '10 koup has alignment problems, too (170 miles).
it has been pulling to the left nearly all the time.

the dealer tried to fake a 2 wheel alignment in their shop (which doesn't have an alignment machine) & said they adjusted the toe-out.
when i called back because it was the same, the service guy said that some forte's have been having problems with this & it takes most of a day at an alignment shop with shims & wedges to fix. i'll be dropping it off for this in a few days. we'll see how it goes.

edit:
i got it back 2 DAYS LATER... and all they did was replace a tire.
and it's still pulling to the left.
now on to round 3
:(
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top