Kia Forte Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Howdy Folks!
Hey my daughter's 2012 EX with about 90k miles was making a clunking sound when hitting potholes. I was SURE it was the front right strut!
So I replaced both front struts. Didn't fix it. Doh! So now I'm thinking now it is likely the right front HUB BEARING.

Looking online, I have seen they sell JUST bearing sets, or hubs, or sets with both hub and bearing.

I have only changed a hub on a Chevy Duramax, which is a sealed bearing/hub assembly.

If anyone has ideas/ tips / pitfalls to avoid, it would be most appreciated. Thanks in advance!

PS when I did the struts, I checked the ball joints/tie rods and they seemed ok.
 

·
Registered
'21 Forte FE 6-Speed
Joined
·
977 Posts
Howdy Folks!
Hey my daughter's 2012 EX with about 90k miles was making a clunking sound when hitting potholes. I was SURE it was the front right strut!
So I replaced both front struts. Didn't fix it. Doh! So now I'm thinking now it is likely the right front HUB BEARING.

Looking online, I have seen they sell JUST bearing sets, or hubs, or sets with both hub and bearing.

I have only changed a hub on a Chevy Duramax, which is a sealed bearing/hub assembly.

If anyone has ideas/ tips / pitfalls to avoid, it would be most appreciated. Thanks in advance!

PS when I did the struts, I checked the ball joints/tie rods and they seemed ok.
Sounds like sway bar end link or control arm to me.
Yeah I doubt it's the wheel bearing unless it's also making a sound like a jet engine when veering left at higher speeds.
This.
 

·
Registered
'21 Forte FE 6-Speed
Joined
·
977 Posts

This is a good process explanation for finding the loose link. After watching, I bet the sway bar links are going bad.
Sounds about right. It's pretty common.
 
1 - 7 of 7 Posts
Top