Kia Forte Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all,

I'm getting my sirius fixed by the dealer today because it says "loading Sirius" and never does anything more. Sirius pinged the unit and confirmed our subscription so it is a safe bet that the issue is hardware related.

I found this forum by Googleing the issue and saw that others had experienced this problem because of an antenna or antenna-mount issue. I'll let you know what they find out.

I have noticed that the antenna on my car looks a bit different than most of the other Forte's that you see, so my real question is: Has anybody else with the Sirius issue also had this 'different' antenna, and is that possibly the source of the problem?

Thanks,

Jim
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
I just got a call from the dealer and they informed me that the radio itself needs to be replaced... (won't be here for a few days)

Interesting, I wonder if my problem is due to a different cause than the other posts I read or if the dealer can't find a problem and is assuming that the head unit will fix it.

Anybody have experience on the matter?
 

·
Registered
Joined
·
41 Posts
i have the same issue.. and it hasn't been fixed in 5 weeks.. keep getting the run-around. It's almost as if my dealer has no clue about the Forte's. I have used this forum to remedy my problems and provide solutions to the tech.

driving me insane, and my free trial ends next month so i won't get to enjoy it anyway but still wanted to get it fixed for down the road
 
1 - 4 of 4 Posts
Top