Kia Forte Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
306 Posts
Discussion Starter · #1 ·
I was installing dome lights while they were on which I know was stupid but all of a sudden they turned off an my speedometer and clock lights turned off and the TPMS light came on and i tried disconnecting the battery and it won't change! please help! my trunk light door lights and speedometer lights dont work! i dont want to take it to the dealoer because I fear they will void my warranty because of the stereo system! can someone help??
 

·
Registered
Joined
·
1,487 Posts
ok, FIRST check fuses..
if fuses are good you might have burned out some bulbs

if fuses were burned out and you replace the fuse still no lights..
then most likely you still have burned out some bulbs.in that case you'll have to pull the dash apart and other light covers for doors/trunk etc. check the bulbs replace bulbs as needed.

Hope this helps you out
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #3 ·
ok, FIRST check fuses..
if fuses are good you might have burned out some bulbs

if fuses were burned out and you replace the fuse still no lights..
then most likely you still have burned out some bulbs.in that case you'll have to pull the dash apart and other light covers for doors/trunk etc. check the bulbs replace bulbs as needed.

Hope this helps you out
I cant lock and unlock or open the trunk from the remote either and i cant lock it from the switch in the car either! :(

which fuses should I check just the ones under the dash or the ones under the hood too?
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #4 ·
the dome lights trunk lights, speedometer lights, clock, electric door lights and the keyless entry do not work! I think I'm going to die. I hope my electrical isn't completely screwed up!!! Is there anything I could do other than the dealor :( I am really afraid they will void my warranty because I have HIDs and a stereo system :(
I checked all fuses they all seem to be good still.
 

·
Registered
Joined
·
1,487 Posts
did you check the fues under the hood..? the multi fuse hmm I'm kind of at a loss here..

ok did you take the battery out? are the battery terminals back on? check to make sure they are the right way and on snug to the battery. just in case ok
not saying your a idiot just think something does not make sence here.
if your car still does not let you open the doors after checking that I'm afraid I can't help you any further from here..

Really sorry about your ride this sucks for sure
hopfully you figure it out in a second or somebody on here has another idea...
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #6 ·
thanks for trying man...Im such an idiot for messing with the dome lights while they were on :( all fuses under the dash and hood are fine. I fear that something in the electricals got burned. Sh***TT I am so screwed. I am going to deinstall the HID's and my CAI tomorrow morning and monday I will take it to the dealor and hope for the best. But please if anyone has a solution please tell me.
 

·
Registered
Joined
·
1,487 Posts
Oh your welcome sorry I could not help more..
I kind of feel bad for you, but just so you know I did something like this once when I was a lot younger and I freaked out.. had no lights etc.. found out it was a fuse I missed, or something like that I was in panic mode and just didn't see it.

So take a couple of breaths try to calm down and take a couple more looks around before you start taking things apart ok?
if after that you don't see anything then I guess you should go ahead with your plan.
Good luck with this
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #8 ·
Oh your welcome sorry I could not help more..
I kind of feel bad for you, but just so you know I did something like this once when I was a lot younger and I freaked out.. had no lights etc.. found out it was a fuse I missed, or something like that I was in panic mode and just didn't see it.

So take a couple of breaths try to calm down and take a couple more looks around before you start taking things apart ok?
if after that you don't see anything then I guess you should go ahead with your plan.
Good luck with this
thanks man I'm just afraid i might have screwed everything up. an I don't know if I should drive it now because I am afraid it might cause something else to get messed up :( I can't believe myself and I know not to do that!
 

·
Registered
Joined
·
1,487 Posts
maybe its a relay that took the heat.
those are hard to check by looking thou, need a voltmeter to do that.
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #10 ·
a volumeter? how does that work?
 

·
Registered
Joined
·
1,487 Posts
has 2 metal probes one positve one neg, sometimes they are clips ends,anyway
if you poke the right areas of the relay/resistor you can find out the amps.. or lack there of.
 

·
Registered
Joined
·
306 Posts
Discussion Starter · #13 ·
It was just an overlooked fuse, lol thanks everyone for you're help! :)
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
3,906 Posts
Problem solved...tragedy averted...LoL

Glad you got it fixed!!!
 

·
Registered
Joined
·
358 Posts
Can someone say DEJA VU?
 

·
Registered
Joined
·
1,149 Posts
another happy example of 'when things go poof'- work backwards from what you did to make the poof- and triple check the simple obvious ones - then panic- then go back and triple check those simple obvious ones again before freaking :)

glad to hear of the happy ending
oh yeah- and this also makes a good point to point out- the kia tech site-
those electrical diagrams show which fuse goes to the dome lights :)
http://www.kiatechinfo.com/index.asp
 

·
Registered
Joined
·
2 Posts
Guess this is about 3 yrs too late.. This just happened to me the other day. Blown fuse should be in the interior fuse box (to the left of the steering wheel). It's a 15 amp fuse that's coupled with another. To remove the plastic coupler, just squeeze both sides as you remove it. The top fuse (labeled room) should be the problem. There is an extra 15A fuse in the engine bay fuse box.
 

·
Registered
Joined
·
646 Posts
Kia's seem to be temperMENTAL when it comes to the electrical. Same BS happened to me on my first forte. F-ing fuse was hidden so it drove me bananas diagnosing why a dome light would cripple an entire car!
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top