Kia Forte Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
I'm trying to install my TK CAI and it is NOT working as planned. I cannot get the intake tube down to the wheel well... Some thing is blocking the path.... Also I do not have this "dipstick" mentioned where they say it should be. Please help, I have a 2011 Koup SX A/T... Help would really be appreciated.
Thanks
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
They are closed now and my cars currently apart. This kind of sucks... haha.
 
Joined
·
2,213 Posts
Lol that does suck! You sure the tube isn't backwards or upside down or they accidentally sent you the one for m/t? What's blocking it down there?
 

·
Registered
Joined
·
312 Posts
He has the m/t I believe. Also, I thought the m/t doesn't have a trans dip stick that the directions are stating? maybe they sent you an a/t one?
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
I have a 2011 Koup SX A/T. I told TK this when I ordered, they did however send me a black edition by mistake instead of the polished like I ordered (I was quite excited and yes I let them know and they said happy birthday :) lol. So maybe there was a mix up with the packaging? I've emailed and PM'd TK so hopefully tomorrow, or come Monday I can hear from them and get this whole deal straightened out. Just so we're clear I am not bashing TK I think they are great and I understand shyt happens (that's how my brother was born) lol I just hope we can fix this. :)
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #7 ·
Lol that does suck! You sure the tube isn't backwards or upside down or they accidentally sent you the one for m/t? What's blocking it down there?
Sorry, to answer your questions there is a coolant line going into the radiator that was blocking it... ALSO the positive harness for the battery seems to be in a different spot that in the guide. I will post pics soon to show you the difference.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #9 ·
Sorry... I'm not sure how yo post pics on the forum... :-/ Any help here? Haha I promise I'm not dumb, just not much knowledge with forums.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #10 ·
Any one else with the same exact model Koup as me that installed their TK CAI? TK followed up with another customer with an 11 Koup, not sure if he has 2.0/2.4 or AT/MT. I also don't have a spot under the battery holder where the mount should screw into, like there was in the manual. If all else fails I will be sending the intake back. :-(
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #11 ·
Success! :) Squeezed the intake in there and it sounds AMAZING! All I need to do is fab up a little bracket down where the filter is to keep it from moving as the mount TK supplies on the intake is useless since the 2011 have a different battery box. Thanks to TK for helping me out, their customer service is top notch...
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top