Kia Forte Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,131 Posts
Discussion Starter · #1 ·
The other day when doing my HID's when I opened the hood I had a feeling it felt funny when i tugged on it. Went to open the hood today and the latch pull just pulls with no results. Guess i'll have to take it into the dealer for my first warranty visit. Hope they have fun trying to get the hood open.
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
3,879 Posts
Keep us posted...you weren't in any "hood opening" contests were you...LoL!
 

·
Registered
Joined
·
1,487 Posts
^^^^
Ahh that sucks.. :(
Hopefully the fix it quick
 

·
Premium Member
Joined
·
112 Posts
I had the samething happen to me. I took it to the dealership and they said that the cable popped out of the brackets and it got pinched. My cable didnt break just got pinched. Yours may be the same, hopefully
 

·
Registered
Joined
·
1,131 Posts
Discussion Starter · #7 ·
OK good. I'd imagine they'd just unbolt the latch thru the grille. At least that's what we did on my buddies MS3 when he had the problem.
 

·
Premium Member
Joined
·
112 Posts
Yea probably. I didnt see what they did. All i know is that it was super quick. If your cable is snapped then it may take a little longer to do.
 

·
Registered
Joined
·
1,131 Posts
Discussion Starter · #9 ·
UPDATE:

I took it in today. I was sitting in the waiting area and the tech came out. He says "So who installed the lights?" I figure Oh great here we go. They are going to deny warranty because of my HID's. I told him I did and he said "Come with me". He took me into the bay and showed me that when I was removing my lights I must have knocked the cable from it's holder. IMO worst design ever. The part sits right above where the headlight is and a minor touch knocks it loose.

Anyway the tech looked out for me and said to just keep and eye on it next time I was messing around under the hood. He told them it must have come out by itself and all was covered for me under warranty. Took about 30 min to fix.
 

·
Registered
Joined
·
733 Posts
lol this happened to me to. Some what easy way to fix it is to take that plastic cover off on the latch, find the cable and just pull it till the hood pops open
 

·
Registered
Joined
·
1,131 Posts
Discussion Starter · #11 ·
lol this happened to me to. Some what easy way to fix it is to take that plastic cover off on the latch, find the cable and just pull it till the hood pops open

No. It came unhooked under the hood. They had to pop the splash guard under the front bumper off and reach up and manually pop the latch.
 
1 - 11 of 11 Posts
Top