Kia Forte Forum banner

Kia forte 2011 1.6 - Manual AC

1043 Views 7 Replies 2 Participants Last post by  Momin
Hello, I have ran into a peculiar problem with My 2011 Forte1.6 - manual AC. The car's AC and recirculation buttons don't light up when i leave for work in the morning, only the fan works, sometimes the buttons would start working on their own after 20-30 minutes of driving; however it almost always works in the afternoon when the car has been sitting in the sun for a while, and when it works it blows perfectly cold air.

Some info that maybe useful:
  1. I have checked all the related fuses and they are all okay.
  2. These problems didn't exist before I installed an android head unit, but i pulled the units fuses to deactivate it but the problem persists even when the head unit is not getting power.
  3. When i turn on the heater, AC blows hot from driver vents and cold from passenger vents, maybe actuator is causing this other issue as well? but I had this issue for more than year.
  4. The defrost button lights up very dim (not visible unless seen in pitch black) unless the other two buttons light up, but when i press the defrost button it makes a clicking noise near Fuse switch board. When the AC and recirculation buttons light up properly, defrost button also lights up brighter.
Someone else is also facing the exact same issue, even though they don't have actuator problems, they couldn't find a solution for it.

If anything is not clear please let me know, English is not my first language.

Any suggestions are welcome. Thanks a lot.
  • Like
Reactions: 1
1 - 8 of 8 Posts
Remove the HVAC control unit. See if it's plug is melted, loose or the wire harness & pins are connected & locked into place.

Can also be the unit is finally going out. Open it up & see what's going on inside. If you do open it. Take before, middle & after pics.
Remove the HVAC control unit. See if it's plug is melted, loose or the wire harness & pins are connected & locked into place.
I have removed the head unit and fiddled with both plugs multiple times, i have even tried to put some WD40 into the plug/socket thinking there maybe carbon/grime in the plug, that didn't work either. I have however not had a look on the wiring harness being shorted out. I will check that today and will report.

If that doesn't work then i'll remove the HVAC system to open it and see if there is anything obvious.

What i just don't understand is that why does it start working when the car sits in the sun for a while in 35c/95f temp. There must be some reason for this bizarre behavior. Thanks.
  • Like
Reactions: 1
Cold contracts, heat expands.

If it only operates as manufactured in high heat exposure, that means the metal contacts move/expand or make contact to complete circuit. It's not solder point on the circuit board. Solder needs extreme heat to liquefy.

Check the wires, plugs.

Check the HVAC blower fan as well. Check & verify the wires are in good condition, the plug/pins as well. Check for burn marks along the wires & at the socket & plug.

Kia/Hyundai, new vehicles are wired like Xmas tree lights, one goes out the others will follow. Instead of that part goes out & the rest are working properly, series vs parallel circuit.

Visit your local Junk/salvage yard for oem/factory bandaid parts.


Last resort is your local dealership
See less See more
  • Helpful
Reactions: 1
Hi, I checked the wires and plugs for both connectors, they are good. I guess the problem must be with the control unit it self. I searched around on other places as well, and so many people have the exact same weird problem. Now i'll open the control unit and check if i can find anything obviously wrong with it, if not, then i'll have to buy a replacement, hope it's not too expensive.

Any Ideas on what i should be looking for when i open the control unit? Thanks.
Okay, i opened the control unit, cleaned it thoroughly, put it back in, same problem. Last resort is to buy a replacement?
Hello, if anyone is still facing this issue, i found the solution and thought i should share it as i know alot of people are suffering from this problem.

The fix is to open the control module, and above the middle dial (Air direction dial) there are two silver capacitors, just change those with the same type of capacitors and voila, everything works perfectly.  I got mine changed from electronics repair shop (tv, stereos etc.)

Picture below for reference.
Circuit component Green Electronic engineering Electronic component Electronic device

Hope this helps someone, I suffered a lot due to this small problem for a long time.
See less See more
  • Like
Reactions: 1
someone Facing exactly the same problem changed theirs with following capacitors and it worked for them.

"Replaced the caps with a 22uf 50 volt and a 47uf 35 volt
:) Works great!! Thank you!!!"

1 - 8 of 8 Posts