Kia Forte Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 ·
I installed my led flasher but it flash to fast. I tried a EP34...same (I installed it on the only place that I can hookup a flash module, it's not at the same place that the US model. I don't know if some thing are like a flash module...maybe wrong place?)


How fix the problem?

Thx
 

·
Premium Member
Joined
·
704 Posts
The flash module is in the same place an all Forte models. Check the unit you bought, does it say LED on the flasher itself, it must say for LED use on the unit.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #4 · (Edited)
The EP34 is not what u need... since it is Load Sensitive.

Look for something not load sensitive.
est-ce que tu peux me proposer quelque chose?...je suis pas trop familier avec l'électronique d'auto??

Merci


Eng: can you suggest some thing?....I don't know well car electronics.

Thx

ps: the flash module are on the wire harness not the frame like on the picture saw on other topics.

Edit: I forgot, when I remove the EOM flash module, the flash still work...it's normal or I didn't change the good one! lol
 

·
Registered
Joined
·
405 Posts
Ask Paul from Diode dynamics
Kia Forte Forum : Sedan and Forte Koup Forums - View Profile: Paul J. McCain

This guy has a lot of lighting stuff for Hyundais and surely for Kias too and has a notable reputation.

Or u may give a look at places like superbrightleds.com


Your blinkers blinks faster 'cause there is less load on the circuit; leds takes less energy, so less amperage. The flasher is made to work at a certain amperage. that's why it goes slower when u add a trailer. An other easy solution would be to add one or two resistances but i don't really like this option.

Finaly, u may try with the Hazard module, but i'm not sure they have the same shape.

Si y'a de quoi, fais-moi signe !
 
1 - 7 of 7 Posts
Top