Kia Forte Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter · #1 · (Edited)
Whats up guys! I figured since I got my car back, it'd be a good idea to re introduce myself hahaha. My name is Nick, I'm from Michigan, I have a Kia Forte LX Sedan 5 speed bone stock, and i love boobies. And my dog.





Yeah so as most of you guys know/remember, 10 days after buying my new Kia, this happened. 1 of 3 times getting hit in 10 days.




I had that stupid HHR rental for 3 and a half weeks. Who knows how long the repair took, but they were waiting on a back ordered part for more than a week. There is a part where the fog lights are supposed to be on higher models that they are missing. The dealer said that when they get word that the part is shipped, i'll have to bring my car back in to get the part installed. So I'm rolling around with missing parts atm.

Here she is all fixed up.




She looks perfect, alignment feels off sometimes, but it differs from day to day. I'm so glad to have my car back finally. I miss driving a stick and the great gas mileage.

As far as mods go? Tints are comin as soon as we get some good weather. I have a buddy looking for some nice wheels/tires for me right now, and I need to do a little research to find a nice muffler to replace my stock one. I'd like to do some interior mods as well, like hiding the wires from my Droid X windshield mount, getting a new shifter knob and boot, and maybe some new floor mats. Also thinking about a white vinyl for the roof. Hoping getting new bright white HID's this week. Would love to swap out the chrome grill for a black one, and tint the taillights slightly to make them a bit darker.

I took the 'forte' badge off today 'well, TRIED is the correct statement. Shit WOULD NOT COME OFF EASY. I did the hair dryer/goo gone/dental floss procedure, and the adhesive WOULD NOT come off. I wore down the clear coat a little bit from scratching away with my nail, prob need to do a little buff and clean up, gotta see how it looks in the morning.

Well, whats new with you guys?

Also, my fucking digital clock froze an 2:59pm. This happen to anyone else? Should i just disconnect the battery and re connect? Nothing i've tried works.
 

·
Registered
Joined
·
1,487 Posts
Wow glad too see your got her back and all is allright ;)

Sucks about your clock.. I've not had that issue.. I did have my clock lose time a few months ago but that in itself was weird..
Idk maybe like you said try to unhook the battery and see, Might work?
if that fails its time to vist the local kia dealer
 

·
Registered
Joined
·
638 Posts
Sucks about your clock.. I've not had that issue.. I did have my clock lose time a few months ago but that in itself was weird..
Well obviously you're a time traveler.

@OP:Good to hear you got your car back, hopefully it still behaves like normal.
 
1 - 9 of 9 Posts
Top