Kia Forte Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Few days ago I started my 2014 kia forte and the rpm's stayed at 0 while revving the engine. Tried driving around but it wouldn't go pass 20mph. It happened 2 other times since and both times it turned over on the second try. Today while sitting idle it completely stalled. Took 3 tries for it to start. What is causing this? It also chews threw bulbs a lot more regularly than ever. Any ideas?
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
4,144 Posts
Any ideas?
Are you mean to your car? Did you cuss at it recently? Did it overhear you talking bad about it?

JK!

Take your car (if you can) to Autozone, or other parts store, that will check your OBDII diagnostics for free. They'll be able to tell you what the problem is...WE CAN'T through this computer!
 

·
Registered
2017 Kia Forte LX
Joined
·
441 Posts
Have you ever had a tune up? That's key to keeping your car running for hundreds of thousands of miles. And if you go to the Zone, grab a bottle of TECHRON Fuel System Cleaner and put it in your gas tank and then go fill up. I use the Techron Fuel Injector Cleaner in my cars every 10,000 miles and have NEVER had a fuel system problem. First thing to do though, is what ForteSX2.4 said. Get it scanned for codes, ask for a print out and post them here. We'll help with what we can.
 

·
Registered
Joined
·
1,321 Posts
Yep, Techron is approved by Kia/Hyundai. Also have read several posts/threads on this on Forteforums.com.

Check your ignition coils/packs.

Spark plugs. NGK, Denso iridium & each spark plug gap.

Fuel injectors might be just dirty/need replacement.

Dirty throttle body.

Clogged/filthy unchanged engine air filter.

Fuel pump?

Hopefully these suggestions minimize & process of elimination help you.
 
1 - 4 of 4 Posts
Top