Kia Forte Forum banner
1 - 8 of 8 Posts

·
Registered
2016 Forte 2.0
Joined
·
130 Posts
Discussion Starter · #1 ·
2016 Forte 2.0
Just installed new battery.
Of course, the clock had to be reset.
But the spot for the instantaneous MPG is now BLANK!
Is this Uh-oh, or am I missing something simple?

To moderator: maybe there should be a section for General Forte Questions? Not year- or model- specific
 

·
Administrator
Joined
·
616 Posts
I think it takes a bit to calculate the MPG (1 tank of gas), maybe that's why it's not displaying yet? Have you tried to "reset" it?
 

·
Registered
2016 Forte 2.0
Joined
·
130 Posts
Discussion Starter · #3 ·
Yes, that display spot works IF you switch to the TRIP mode. Just doesn't work for MPG. Tried to reset.
(It's a Type A display per O.M.)
Thinking that we'll drive it a while, then fill the tank. After all, it worked with new battery 2 yrs. ago.
 

·
Registered
'21 Forte FE 6-Speed
Joined
·
320 Posts
Perhaps a better question is why your battery only lasted 2 years. All of my batteries have lasted at least 6
 

·
Registered
2016 Forte 2.0
Joined
·
130 Posts
Discussion Starter · #5 ·
Good question. This car is pampered. It always starts with very little cranking.
Bad battery is my vote.
During its last start-up, the old battery dropped to 6 volts! Only 2 yrs 8 months old.
 

·
Registered
Joined
·
10 Posts
What's the brand name of the two year-old battery?
Where did you purchase it?
How many miles on that 2016 vehicle?
 

·
Registered
2016 Forte 2.0
Joined
·
130 Posts
Discussion Starter · #7 ·
AZ Duralast.
Replaced free with another, <3 yrs old = free replacement.
76xxx miles on car.

I filled gas tank. Started car. Pushed RESET on the steering wheel, MPG is back! 😎
 

·
Registered
Joined
·
14 Posts
I wish mine would disappear for good. Drives me crazy as it's so off anyway....I am lucky to get 300 miles to a tank when it says 420 when I fill up. Makes me depressed, lol!
 
1 - 8 of 8 Posts
Top