Kia Forte Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter · #1 ·
I just installed a turbokits CAI the other day, and when i start the car it seems to make a rattle noise then it goes away, is this normal? it doesnt do it when im driving, it just does it for a few seconds after i have started the car
 

·
Registered
Joined
·
1,241 Posts
i had this problem.. i did a triple check after installed it.. make sure you tighten ALL clamps and do that battery tray too. one time i had a whistle sound when accelerating..so i did another check on everything including the filter. now the sound is gone for now.. it'll probably wont be the last time neither. haha

i also bought more cooling tape too..
 

·
Registered
Joined
·
1,241 Posts
i check like once a week.. haha
 

·
Registered
Joined
·
231 Posts
Discussion Starter · #5 ·
haha thats dedication, i wish i had some quick jack stands so i could check stuff like this often
 

·
Registered
Joined
·
1,241 Posts
i actually have the koup parked all the way up the inclined driveway and go through danger and get on my back and check the filter..the same way i installed it. lol
 

·
Registered
Joined
·
205 Posts
i have the same problem!
maybe i need to go back and check that everything is tighten.
it started like 2 weeks after the install so maybe it got lose.
good thing for me its only when i let go from the gas from
high rpms. normal driving it wont make noise
 

·
Registered
Joined
·
34 Posts
i hear the whistle sound too, if you barely push the gas, you can hear it. Its the throttle body opening up, so if you lightly push the gas it opens a little sucking air in, making a whistle sound.
 

·
Registered
Joined
·
1,241 Posts
^oh ok, makes sense davidsxspeed.
 

·
Registered
Joined
·
34 Posts
no problem
 

·
Registered
Joined
·
1,804 Posts
I'm wanting to go for this CAI, just hoping there are no installation probs with this because it looks and sounds so sweet.
 

·
Registered
Joined
·
34 Posts
its is sweet, i got it but had to go to work. I coudnt wait so i put it in at 11:00 at night and it didnt even take me an hour. its easy and no problems at all.
 

·
Registered
Joined
·
1,804 Posts
its is sweet, i got it but had to go to work. I coudnt wait so i put it in at 11:00 at night and it didnt even take me an hour. its easy and no problems at all.
Sweet. What did you use for a bypass valve??
 

·
Registered
Joined
·
34 Posts
bypass valves are for turbos, its in place of a blow off valve. If your talking about the extra tube the come down from the top of your engine its supplied with the CAI.
 
1 - 14 of 14 Posts
Top