Kia Forte Forum banner
21 - 39 of 39 Posts

·
Registered
Joined
·
1,423 Posts
You can try an old timers mechanic trick.

While the vehicle is running, unplug at each ignition coil pack wire harness/pigtail & listen for the rpm drop.

If it doesn't drop rpm, the coil maybe out or malfunctioning. Can see if that will help.

Let us know what the fix was.
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
If you have every coil back in it's original position, clear the codes and then start the car. If the P0302 comes back, replace the coil on #2. Clear the code and then start the car and see if P0302 come back up. I'm willing to bet it doesn't. It's pretty strange that #2 on your car has gone bad and #2 on my car did too. Coincidence?? Maybe not.
 

·
Registered
2021 Kia Forte GT-Line
Joined
·
297 Posts
If you have every coil back in it's original position, clear the codes and then start the car. If the P0302 comes back, replace the coil on #2. Clear the code and then start the car and see if P0302 come back up. I'm willing to bet it doesn't. It's pretty strange that #2 on your car has gone bad and #2 on my car did too. Coincidence?? Maybe not.
Every time he moves that coil the misfire moves to the new cylinder and he didn't clear the codes between moving.. coil is bad
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
Oh, I know that. All I'm saying is that every time he moved it, it misfired the next cylinder. The reason he had all the misfire codes is because he didn't clear the code each time he moved it.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #26 ·
I cleared the codes and I have only two. That's with switching the bad coil pack with one of the good ones. Same result and cleared codes in between. New coil packs ordered off ebay and should be here by the 18th or sooner. Spark plugs still not delivered to auto parts store. Due to 6 inches of snow here in TN. Will update after installing new parts.
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
Where in TN are you? I was born and raised there. Spent most of my life in Waverly, then Nashville. I also lived in Kingsport and Shelbyville for a while.
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
No kidding. My Dad was born and raised in Cheatham County. Do you know where Neptune is?
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
4,380 Posts
No kidding. My Dad was born and raised in Cheatham County. Do you know where Neptune is?
Neptune...isn't that close to Uranus? :devilish::devilish::eek::p

In Missouri:

Font Screenshot Chocolate bar Brand Logo
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
Are you familiar with Bartons Creek, BTCC? There's a bluff there that we used to jump off of into the creek when we were kids. No way in hell I'd do that nowadays!
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
Oh well, if you ever get to Southside, ask someone there about both of them. They may not be popular areas anymore.
 

·
Registered
2012 Forte5 SX & 2018 Forte5 SX
Joined
·
30 Posts
On way home check engine light came on. Got home and hooked up code reader and got the P0302. Just replaced spark plugs a couple weeks ago. Also a new AEM air filter installed also.When giving it gas it was sluggish at times. But when I took foot off gas pedal check engine light went off. Foot back on and check engine light back on. Car has 104,777 miles on it. Would replacing just coil pack fix issue.
Check coil, these cars have a known issue with coils failing or the RFI spring inside of it. It could just be a bad coil as well.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #37 ·
Got them yesterday and installed along with Bosch spark plugs. Runs great and no more misfires. Only thing is the locking clip on electrical connector that goes on the coil pack. It does not lock on all four coil packs. Connector is on as far as it can. Other than that, all good so far.
 

·
Registered
2017 Kia Forte LX
Joined
·
517 Posts
Was it like that before you started? Reason I ask is if it was not fully clipped to start with, I wonder if that triggered the issue? Mine lock on all 4 just fine.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #39 ·
Was it like that before you started? Reason I ask is if it was not fully clipped to start with, I wonder if that triggered the issue? Mine lock on all 4 just fine.
They where fully clipped when it was misfiring.
 
21 - 39 of 39 Posts
Top