Kia Forte Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
So a while back I posted something about having problems with the power cutting off at 3000 rpm on any gear.

I figured out this only happens with extremely humid weather.

This happens quite often nowadays, since its been very humid here lately.

Last time this happened I got the "P0335 Crankshaft Position Sensor Malfunction - Circuit A." error.

When that happens, I usually park the car for about 10-15 mins, and when I come back the problems gone.

Any ideas on what can be done, would be appreciated.
 

·
Premium Member
Joined
·
5,180 Posts
^yep..same issue on my last accent. Its the sensor overheating and quitting. I would drive a while and car would die..let it cool and drive a while. Finally got home and got same code. Replaced c.p.s. and never had the problem again. Use a lil dielectric grease on the connector to ensure a good seal and corrosion protection.
 

·
Registered
Joined
·
21 Posts
So a while back I posted something about having problems with the power cutting off at 3000 rpm on any gear.

I figured out this only happens with extremely humid weather.

This happens quite often nowadays, since its been very humid here lately.

Last time this happened I got the "P0335 Crankshaft Position Sensor Malfunction - Circuit A." error.

When that happens, I usually park the car for about 10-15 mins, and when I come back the problems gone.

Any ideas on what can be done, would be appreciated.
Did you replace the crankshaft position sensor? And did it rectify the issue?

I have been having the exact same problem you describe here, the engine just cuts off at 3000rpm sometimes and will randomly stall while at idle. I have a code reader and it wasn't giving an engine light/code for a while but finally managed to get it to show up once when the engine stalled. Same error code. So I ordered the part and will replace it anyways but I'm just wondering if it helped your problem?
 
1 - 4 of 4 Posts
Top