Kia Forte Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello everyone,
I'm new to the forum, and I must say I was ecstatic to find a site like this for Koup owners! We just purchased our Koup last week (SX Manual Trans) and I've been unable to use the bluetooth function. It pairs with my TMobile MyTouch 4G just fine, and sometimes it even says that it's connected--it always says it's connected on the phone, at least. But anytime I press the voice prompt button, it always displays "Downloading Phonebook" on the screen and never does anything else. Even drove around for an hour waiting for it and nothing changed. (Of course, I didn't mind the drive at all! :D)

My hubby also has a MyTouch 4G. Pairing and connecting for him produce the same exact results. PLUS, we've gotten a loaner car (while the dealer puts some final touches on our Koup), and the loaner Forte Sedan does the same exact thing too!

Has anyone gotten their TMobile MyTouch 4G to pair & connect AND be able to make calls? And if so, can you tell me what I'm doing wrong?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I'm sure it's just something I'm doing wrong.

OrangeCrush, was there something special you had to do? You know... maybe stand on your head, or perhaps step three times to the left, or maybe trace mystical symbols in the air? *grin*
 

·
Registered
Joined
·
191 Posts
I'm sure it's just something I'm doing wrong.

OrangeCrush, was there something special you had to do? You know... maybe stand on your head, or perhaps step three times to the left, or maybe trace mystical symbols in the air? *grin*
Hmm it worked with my blackberry... I got so sick of talkin through speakers when i bought mytouch 4g i never tried it.. Ill try for u later and tell u if mine works and if it works ill tell u exactly what steps i took =)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Okay... so I was able to pair, connect, and actually talk on the phone with the Forte Sedan loaner car (meaning it got past the 'downloading phonebook' thingie), but I don't think I did anything differently. *scratching head* Maybe my phone just needed to be rebooted. Well... only thing left is to try it again with my car. Hopefully I'll get it back soon. *drumming fingers on the table*
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Hmmm... I thought I had done that on one try or another. But, maybe I just didn't get everything cleared after the initial failure. Now that I've successfully paired/connected with the loaner Forte Sedan, I have hope that the next try on my Koup will finally work. :) I will definitely delete the phone from the car AND the car from the phone before I try again. Thanks for the suggestion! And of course, I'll be pinning the dealer down for help before I take the car home. *wink*
 

·
Registered
Joined
·
604 Posts
I had the exact same problem with my Android. My blackberry had no problem at all though. I eventually ended up completely wiping my phone, reloading, deleting the phone from my car and trying again. It finally works now. However, it does still take a good 5mins at times before it will stop saying "Downloading Phonebook" and actually work.

I don't know if you have Twitter on your phone, but if you do... Goto People>Menu>View and leave Twitter unchecked. Since Twitter tends to have a brazillion contacts it may screw things up. When i have it checked it nevers seems to fully connect.

I believe i started a thread in this forum with the same problem.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 · (Edited)
Well heck, RunOfLuck, I thought I had searched thru all the posts and didn't find anything specific to the MyTouch 4G. Must have missed yours. :( Posted my own after trying all the suggestions for other phones.

As for my status... Finally picked up my car last night and worked with the dealer until I was able to connect. Yay! But it first failed, meaning I was able to pair and connect, but the "downloading phonebook" message wouldn't go away. So, with the dealer's help, I went thru this process:

On my phone, I deleted my call history and the bluetooth headset I already had paired, then powered off the phone. On the car, I deleted the phone and turned it off. Gave it a few minutes, then started the car again and powered my phone on. Turned Bluetooth on for the phone and in the settings made it 'discoverable' (which it does for something like 119 seconds or so). On the car, went to "setup", "phone", and "pair". Back on the phone, I ticked the "scan for devices" option. The phone asked for the validation code (0000) almost immediately. Typed it in and the car spoke "Phone Paired", while on the phone it listed "FORTE KOUP--paired but not connected". On the phone, I tapped the newly paired Forte Koup entry and the car's display read "Kat-MyTouch 4G Connection Complete". Now... we'd already gotten thru these steps successfully once. But when I pressed the talk button on the car this time, instead of displaying "downloading phonebook" on the car's display for an eternity, it asked me for a command almost immediately. Yay! And away we went!

I have absolutely NO idea what we did differently the 2nd time around. Perhaps it's like RunOfLuck suggested--it was trying to download external contacts (I don't have Twitter, but I do have a lot of Facebook contacts) and by restarting the phone and the car, it stopped that process. I don't know. At this point, I don't care. :D

Thanks for all your help & suggestions, everyone! Happy driving! :cool:

****EDIT****
Oh, there's one step in there I forgot to mention. After the connection between the two was complete, my phone displayed a message that said something to the effect of "FORTE KOUP is requesting access to your phonebook" and it gave me an option to accept or deny, and of course, I accepted it after ticking the "always accept" button. On hindsight, perhaps it was this step that I didn't do right the first time. Maybe by accepting the Koup's inquiry on the phone right away, it made a difference. *shrug* Who knows?
 
1 - 11 of 11 Posts
Top