Kia Forte Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi ALL
I have a 2010 koup auto , done 190ks / full service history / 1 owner
in the last 2 days in the mornings , ( COLD ) , It Has rough idle on start up ! i don t rev it at all to warm it up ,
When i drive off and in minutes it drives perfect ?
Besides the obvious go to dealership to diagnose $$
Any suggestions out there . I got basic mechanical skills ..
Cheers Gordo
 

·
Registered
Joined
·
102 Posts
Have the battery load tested. The cars of today are very sensitive to voltage changes. It could be something as simple as dirty connections on the post and terminal clamps to a cell starting to go bad in the battery. How long have you had the car and how old is the battery? Vail5 asked a great question when he asked about codes.
 

·
Registered
Joined
·
102 Posts
It could also be time to run some Techron Fuel System Cleaner through the gas tank. Maybe a dirty injector. Have you ever cleaned the injectors?
 

·
Registered
Joined
·
7 Posts
Hi ALL
I have a 2010 koup auto , done 190ks / full service history / 1 owner
in the last 2 days in the mornings , ( COLD ) , It Has rough idle on start up ! i don t rev it at all to warm it up ,
When i drive off and in minutes it drives perfect ?
Besides the obvious go to dealership to diagnose $$
Any suggestions out there . I got basic mechanical skills ..
Cheers Gordo
I've seen a gdi system leak after shut off causing the car to be a little flooded when first started. And it was a tbs on several Kia/Hyundai models. Not sure if you're falls in this category and hopefully it's something easier than that.
 

·
Registered
Joined
·
1,054 Posts
I've seen a gdi system leak after shut off causing the car to be a little flooded when first started. And it was a tbs on several Kia/Hyundai models. Not sure if you're falls in this category and hopefully it's something easier than that.
2010 would not be GDI.
 
  • Like
Reactions: mobileterminaluser

·
Registered
Joined
·
7 Posts
2010 would not be GDI.
Okay, I wasn't sure when Kia started using direct injection. Was just trying to assist. I got to take my 2020 forte GT back in. It's starting to misfire a few times on start up and I'm thinking that's my issue. But it's under warranty so they can figure it out lol
 
1 - 7 of 7 Posts
Top