Kia Forte Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Last night and this morning my radio would not work. First time the temp has gotten below 0 degrees F... the Sat radio worked, although slow to respond, it changed stations, but would not receive any FM stations!

Did it last night on the way home from work, then again this morning. But 3 hours later, when I started the car again expecting the radio to not work again, it worked fine... that was the time I was gonna run it by the dealer!

Anyone else in cold climates had this problem? :confused:
 

·
Registered
Joined
·
289 Posts
I live in SoCal....never gets that cold here. Sorry
 

·
Registered
Joined
·
1,796 Posts
-31F and working fine albeit sluggishly on the displaying of the mp3 names. Haven't tried playing a CD at these temps though. Display is back to being responsive once the interior warms up a little.
 

·
Registered
Joined
·
1,149 Posts
Last night and this morning my radio would not work. First time the temp has gotten below 0 degrees F... the Sat radio worked, although slow to respond, it changed stations, but would not receive any FM stations!

Did it last night on the way home from work, then again this morning. But 3 hours later, when I started the car again expecting the radio to not work again, it worked fine... that was the time I was gonna run it by the dealer!

Anyone else in cold climates had this problem? :confused:
here in florida- (nice balmy 75 degs right now)
haven't had that problem-
i am wondering if the problem is antenna related- ie-
the metal contact points on the outside of the car contracting and causing loss of signal from the FM antenna- yet- still allowing higher powered SAT signal thru?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
-31F and working fine albeit sluggishly on the displaying of the mp3 names. Haven't tried playing a CD at these temps though. Display is back to being responsive once the interior warms up a little.
Hum... well I dunno if that's good or bad for me! lol... I was starting it to take it by the dealer on the way home when it started working again and has everytime since. It's not quite as cold as it was last night (8*F)...

thanks for the replies! :D
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
did it again this morning! Stopped by the dealer an talked to the service tech at the desk even though I could not duplicate it for them, he said it's probly the radio and ordered me another one. Works for me...

I have a little more info, the AM nor FM radio work, the display is fine, sat radio works, all buttons work, just no sound when it's cold. Turn the radio off and back on, no change, even when warmed up. But turn the car off and back on once warm and it will work like advertised... :confused:
 

·
Registered
Joined
·
288 Posts
-31F and working fine albeit sluggishly on the displaying of the mp3 names. Haven't tried playing a CD at these temps though. Display is back to being responsive once the interior warms up a little.
Same goes for me - the display is just like on the gas pumps when you're outside. :)
 
1 - 8 of 8 Posts
Top