Kia Forte Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
Okay, so this has happened to me three times so far, I contacted my dealer the second time it happened and they gave me a 'remedy', but I'm wondering if anybody has run into the problem....

My tire pressure light - looks like ( ! ) turns on when I start the vehicle and remains on for the duration of my drive, I checked all pressures and they were spot on. After about a week of driving, the light turns off without fail, then in another week it turns back on.

The manual says that if the light turns on and stays on then it's a system problem, it should - if properly functioning - only illuminate for a few seconds if your pressure is low.

The second time this happened the dealer said to inflate the tires all to 36 and that I have to drive a decent distance for the system to get a new accurate reading. However the light is back on again!

Here's the kicker, every time I go to bring the car in the light goes off again :(

Anybody have this issue?
 

·
Registered
2021 Forte GT w/GT2, Currant Red, SXTH Element Intercooler Kit, Evilla Exhaust, Takeda S2 Intake
Joined
·
3,847 Posts
Sounds like you have a defective Tire pressure Monitor in one of the wheels...

Is your dealer doing a relearn of the TPMS when you bring it in -- where they reset the system with a computer and have to go to each wheel and reset them with a monitor?
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #3 ·
So far they haven't done anything yet, as I only called them the second time the light went on then followed their directions in inflating the tires to 36. The light went off after about a day or so of 36 psi and they assumed that the inflation fixed the problem, clearly not :S
 
1 - 3 of 3 Posts
Top