Kia Forte Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
While driving around 100 mph on a cold highway, the TPMS light came on and off by itself when I slowed down. This is not the under inflated warning light but the letter "TPMS".

It seems like the light comes on when the speed is high and goes off when I drive with the normal flow.

I checked the air pressure on the 4 tiers and they were fine. I checked the value stems for any movement and they were solid and not moving.

I guess something inside the sensor must be loose a little bit and maybe the high speed would cause it to move (like battery connection in the TPMS sensor itself ?) and trigger the warning light. It's not worth my time to visit the dealer yet, since it's so hard to replicate near the dealer !
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #5 ·
Just to be clear, it's NOT the under inflated warning light, but the actual TPMS system warning light. The tire pressure was normal all the time.

Has anyone seen TPMS light come on and off by itself during normal driving and on highway ?

I could not reproduce the problem driving around suburbs. I won't take it to the dealer until it's reproducible. Furthermore, I really don't depend on TPMS system anyway. I frequently check tire pressure - especially with the winter temperatures fluctuating over 10 degrees F. I noticed Forte is VERY sensitive on ride quality if I over inflate by 1 psi and somewhat sluggish if I under inflate.
 
1 - 2 of 2 Posts
Top