Kia Forte Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Okay I just need to vent. I just got new door speakers in my car. I spent more money than I would like to mention and it took about 6 hours. Now the light around the speaker doesn't work. :( So now I have to take my car back to the installers tomorrow and hope they can get me in. O what fun times.

Side Note
The speakers are the JL C2's and they sound great.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
I got all 4. I got a 400W amp to go with them. Now you can crank the tunes and not worry about the factory door speakers blowing
 

·
Registered
Joined
·
587 Posts
Sweet speakers for SURE!

Hope the installers fix the lighting problem....I'm surprised that they did not mention it before.....

Good luck :)
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Spent another 3 hours at the installers today and they still didn't fix it. They said they are going to have to research and try to see if anybody else has had this problem. We will see how that goes
 

·
Registered
Joined
·
3,919 Posts
TBH with you, i am not trying to patronize them but i am guessing the LEDs were somehow hooked to the stock speaker wire. Adding amp, and cutting a couple of wires to install the new speaks the wires for the leds may have got lost somewhere.

I had a friend who had a set of home speakers that he wired leds to the speaker wires and the leds played to the music while not using a separate power source.
 
1 - 6 of 6 Posts
Top