Kia Forte Forum banner
21 - 40 of 63 Posts

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #21 ·
Wipers & mist work.

Got the (new to me) BCM from the 2011 Forte sedan eco automatic & installed in my 2010 SX.

Nothing. I lost the use/function & illumination of foglights.
83440


I checked the other 2 areas,
83441
nothing. No relays or fuses. Just wires. I also checked the passenger side kick panel. The same, just wires no relays or fuses.
 

·
Registered
Joined
·
3,094 Posts
After installing the "new" BCM did all the lights (except fogs) that were working continue to work and all the lights that weren't working continue to not work?
 

·
Registered
Joined
·
3,094 Posts
Wipers & mist work.

Got the (new to me) BCM from the 2011 Forte sedan eco automatic & installed in my 2010 SX.

Nothing. I lost the use/function & illumination of foglights. View attachment 83440

I checked the other 2 areas, View attachment 83441 nothing. No relays or fuses. Just wires. I also checked the passenger side kick panel. The same, just wires no relays or fuses.

Might need to disconnect the multi-connectors and check the pins.
 

·
Registered
Joined
·
3,094 Posts
Mobileterminaluser,

These are not working:

Left halo
Left parking (headlights work?)
Left tail lights and brake lights (right side works?)
Pass window control lights (Dome light works?)
Ignition key light
Hazard button light
HVAC lighting
Steering wheel switches lights

With original BCM Everything else worked...fog lights too?
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #26 ·
The illuminations not working:
▪︎Steering wheel controls,
▪︎HVAC control, ignition ring, pass window button,
▪︎hazard triangle icon,
▪︎front headlight passenger side (park mode) amber,
▪︎passenger rear (trunk lid & q panel) combination brake lights don't work at all.

What works & illuminates:
▪︎Both OEM/factory headlights (lows, hi, fogs blinkers).
▪︎Hazards lights (all 6).
▪︎Sun/moon roof (open/close) controls.
▪︎Dome/courtesy lamps.
▪︎Key fob open, unlock, trunk, panic.
▪︎Kenwood DDX773BH stereo.
▪︎Steering wheel controls (call, mute, mode, hang up.
▪︎Driver door controls (windows. lock/unlock, side power mirriors).
▪︎driver rear (trunk lid & q panel) combination brake lights.
▪︎cluster gauges (fuel, rpm, speed, trip/odo).
▪︎HVAC knobs, temp, fan speed, selector. recirculation, rear defrost, etc.
▪︎power steering.
▪︎wipers (all speeds) & mist.
▪︎traction control on/off.
▪︎brakes.
▪︎key/headlights seatbelts on reminder chime.
▪︎driver, pass & trunk ajar icon.

Basically my Forte works as if there's nothing wrong. Just the damn passenger rear trunk & panel brake lights completely not working, the steering wheel controls not illuminating, pass door window not illuminating, HVAC not illuminating, passenger front headlight (park mode) amber.

I don't know where else to look at?
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #27 ·
I was hoping the BCM from the 2011 Forte sedan eco from junk/salvage yard would work. I got remote/fob as well. Still the same problems & fogs were not operating & fog icon wasn't illuminated on cluster gauge.

Drove for an hr, city & highway. Got home disconnect batt installed my Forte's original BCM. Same problems. I did get my fogs back.
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #28 ·
Would there be relays in the trunk area?

I don't remember any boxes being there. Just wires/bundled wrapped up wires. I'll look tomorrow.
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #29 ·
After installing the "new" BCM did all the lights (except fogs) that were working continue to work and all the lights that weren't working continue to not work?
The junk/salvage yard 2011 BCM didn't change or fix the electrical problems. I lost use of fogs/ green illumination fogs on icon.
 

·
Registered
Joined
·
3,094 Posts
The illuminations not working:
▪︎Steering wheel controls,
▪︎HVAC control, ignition ring, pass window button,
▪︎hazard triangle icon,
▪︎front headlight passenger side (park mode) amber,
▪︎passenger rear (trunk lid & q panel) combination brake lights don't work at all.

What works & illuminates:
▪︎Both OEM/factory headlights (lows, hi, fogs blinkers).
▪︎Hazards lights (all 6).
▪︎Sun/moon roof (open/close) controls.
▪︎Dome/courtesy lamps.
▪︎Key fob open, unlock, trunk, panic.
▪︎Kenwood DDX773BH stereo.
▪︎Steering wheel controls (call, mute, mode, hang up.
▪︎Driver door controls (windows. lock/unlock, side power mirriors).
▪︎driver rear (trunk lid & q panel) combination brake lights.
▪︎cluster gauges (fuel, rpm, speed, trip/odo).
▪︎HVAC knobs, temp, fan speed, selector. recirculation, rear defrost, etc.
▪︎power steering.
▪︎wipers (all speeds) & mist.
▪︎traction control on/off.
▪︎brakes.
▪︎key/headlights seatbelts on reminder chime.
▪︎driver, pass & trunk ajar icon.

Basically my Forte works as if there's nothing wrong. Just the damn passenger rear trunk & panel brake lights completely not working, the steering wheel controls not illuminating, pass door window not illuminating, HVAC not illuminating, passenger front headlight (park mode) amber.

I don't know where else to look at?

The wiring schematic isn't helping because the only thing common to all these inop lights is the BCM! I don't see a connector or fuse that is common to all of them!!!

I hate to beat a dead horse...but did you check the fuses' continuity with a ohmmeter or just look at them?

Logic says that if you short a wire it burns out a fuse or pops a circuit breaker!

tc0566 gave some advice - did you try swapping another 10 amp fuse in that position?
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #33 ·
The wiring schematic isn't helping because the only thing common to all these inop lights is the BCM! I don't see a connector or fuse that is common to all of them!!!

I hate to beat a dead horse...but did you check the fuses' continuity with a ohmmeter or just look at them?

Logic says that if you short a wire it burns out a fuse or pops a circuit breaker!

tc0566 gave some advice - did you try swapping another 10 amp fuse in that position?
I used a multimeter at the engine fuse box & at the driver side fuse box. Also removed, visually & with multimeter checked each mini amp fuses.

Will check them all again.
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #34 ·
The wiring schematic isn't helping because the only thing common to all these inop lights is the BCM! I don't see a connector or fuse that is common to all of them!!!

I hate to beat a dead horse...but did you check the fuses' continuity with a ohmmeter or just look at them?

Logic says that if you short a wire it burns out a fuse or pops a circuit breaker!

tc0566 gave some advice - did you try swapping another 10 amp fuse in that position?
Exactly, no blown/burnt inoperative fuse. I even changed all the relays. Still the same.
 

·
Registered
Joined
·
3,094 Posts
What fuse box and specifically what fuse position were you using for your fuse circuit tap? Is there actually power to all the fuses?

I would check the internals of that box. Look at the fuse box power bar (for the fuse location you were using) and see if the lead wire is burned out.
 

·
Registered
Joined
·
3,094 Posts
Multi connectors? At the BCM or kick panels?
Engine harness connections: At the firewall, at each major junction, even the fuse box you were working with. You must have fried something to make it act this way.

The BCM is the most obvious common source for all your electrical problems you have - but you changed that and all the problems are the same, so that's not it.
 

·
Registered
Joined
·
108 Posts
The wiring schematic isn't helping because the only thing common to all these inop lights is the BCM! I don't see a connector or fuse that is common to all of them!!!

I hate to beat a dead horse...but did you check the fuses' continuity with a ohmmeter or just look at them?

Logic says that if you short a wire it burns out a fuse or pops a circuit breaker!

tc0566 gave some advice - did you try swapping another 10 amp fuse in that position?
Actually pulling that right tail lamp fuse does create every issue he lists. Halo on left is off without the fuse as well as passenger park lamp, power window button no longer lights up on passenger door and interior lights to ac controls are not working without that fuse as well as all lights on steering wheel are out without that fuse and and that's with headlights on . Put the fuse back in and all works as should. Pic of fuse box shows the fuse that was pulled to create his issues on my 2011. Pink wire bottom left of diagram shows it controls both headlamp and tail lamp on right side and runs to fuse RH tail lamp.
83454
83455
83456
83458
 

·
Registered
Joined
·
3,094 Posts
Actually pulling that right tail lamp fuse does create every issue he lists. Halo on left is off without the fuse as well as passenger park lamp, power window button no longer lights up on passenger door and interior lights to ac controls are not working without that fuse as well as all lights on steering wheel are out without that fuse and and that's with headlights on . Put the fuse back in and all works as should. Pic of fuse box shows the fuse that was pulled to create his issues on my 2011. Pink wire bottom left of diagram shows it controls both headlamp and tail lamp on right side and runs to fuse RH tail lamp. View attachment 83454 View attachment 83455 View attachment 83456 View attachment 83458
Let's hope you are correct! It may not be the fuse, but a fried wire behind it too...
 

·
Registered
2010 Kia Forte Koup SX 2.4L 6MT Theta 2, Titanium silver metallic.
Joined
·
976 Posts
Discussion Starter · #40 ·
I took stuff apart to see if I can find any other hidden relays.
 
21 - 40 of 63 Posts
Top